Back to overview

Update of Components on Ascenti Software website

Aug 26 at 04:00pm PDT
Affected services
Ascenti Software

Resolved
Aug 26 at 04:00pm PDT

Website is briefly unavilable during the update of plug-in on the ascenticorp.com